Turn off selection of the first preselected item in autocompletion for space key

Hello,

I would like to thank creators for the brilliant IDE. And would like to ask a question: is there a way to turn off selection of the first preselected item in autocompletion for space key.

The situation is quite funny here: if "preselect the first suggestion" if configured to "always" in "code completion" branch of settings, it's completely impossible to write the word "in" in code, because IDE selects "input" when space is pressed.

Tab and even Enter keys are OK for selecting, but is there really a need for space key?

Hope this is configurable.

Thanks in advance.

1 comment
Comment actions Permalink

There is no way to configure preselection separately for each completion character. Note that "preselect always" is not a default setting, it's something that you've selected yourself.

Not being able to type "input" is of course a bug. Please file a YouTrack issue and provide a code example where completion doesn't work as appropriate.

0

Please sign in to leave a comment.