Annoying indexing

I use pycharm 2.0.2 on Ubuntu 11.10 x64, and i actively use many desktops (first for web brouser, second for pycharm etc). So i frequently switch between this. When Pycharm take focus - is start indexing project files and i can't work from half minute to minute after switch between desktops! How can i disable this checking changing of files?

6 comments

Solved - find this:

Settings / General - Synchronize files on frame activation

Now - i'm happy :-)

1

Do the files actually change? If not, there should be no indexing going on.

0

Not, files actually not been changed, but Pycharm always index directory when IDE window take focus. It's stopped after i disable settings in my prev message.

0

Are there any symlinks in your project path? Could you please attach the log file (Help | Reveal Logs)?

0

this is really annoytin, i too had to deactive the sync in the general setting, everytime i changed focus the indexing even was taking place. in the big projects i needed to wait about 7 seconds before i could start using pycharm again.i'm running 2.0.2 under Sun Java in mint12



Attachment(s):
log.tar.gz
1

Please sign in to leave a comment.