PyCharm and Subversion via HTTPS with client certificates

I am using PyCharm 2.0.2 and trying to access repositories that are available via HTTPS, it runs Apache with mod_dav and mod_dav_svn 1.6.16.

When I do something like

svn co https://our.server/repository/branch

on the console, it correctly asks for my client certificate file (here I enter path to PKCS#12 file), for the passphrase for this file, and for my password on the server. After all of that it checks out my working copy successfully, even svn:externals which point to same server. This is how it looks in the access_log on the server:

11.22.33.44 - - [07/Mar/2012:21:52:36 +0400] "OPTIONS /messaging HTTP/1.1" 401 464
11.22.33.44 - merlin [07/Mar/2012:21:52:41 +0400] "OPTIONS /messaging HTTP/1.1" 200 189
11.22.33.44 - merlin [07/Mar/2012:21:52:41 +0400] "PROPFIND /messaging HTTP/1.1" 207 649

Then I am trying to do the same checkout from PyCharm (and then to create a new project based on that working copy).

  1. In the File->Settings->Version Control->Subversion in the "Edit network options" I add a path to the same PKCS#12 file, and enter a passphrase into the field below.
  2. Select VCS->Checkout from Version Control->Subversion, then "SVN Repository Browser" window appears. I enter repository path, click a "+" icon to choose desired branch, but PyCharm displays an error message there: "svn: OPTIONS of /messaging: 403 Forbidden (https://server)"

Access_log on the server looks like this:

11.22.33.44 - - [07/Mar/2012:21:04:54 +0400] "OPTIONS /messaging HTTP/1.1" 403 274

That's all. PyCharm receives that 403 and ceases to work.

I tried to turn off client certificate checking temporary; then PyCharm asked for server username and password and checkout works. This means, our server answered with 403 when cerificate was required because PyCharm hasn't sent my certificate.

How do I make PyCharm to work with SSL client certificates?

2 comments
Comment actions Permalink

Please check that your request doesn't go through proxy:

1) check whether (if you use proxy settings inside PyCharm) Settings | Version Control | Subversion | Use PyCharm general proxy settings as default for Subversion

is turned off

2) check Subversion proxy settings (in Settings | Version Control | Subversion | Subversion configuration directory check where's the configuration directory)

also, Subversion settings can be viewed through Settings | Version Control | Subversion | Edit Network Options...

-----------

Also, there might be the case with renegotiation, so try to put the following line into idea.exe.vmptions file:

-Dsun.security.ssl.allowUnsafeRenegotiation=true

0
Comment actions Permalink

I alredy have all proxy-related options in PyCharm turned off, because I am not using proxy at all.

I have no file "idea.exe.vmoptions". I am using Linux, if that matters. There is "bin/pycharm.vmoptions", which is used by pycharm.sh startup script. I've added suggested line into that file, but this changed nothing.

0

Please sign in to leave a comment.