setting to change default import behaviour

Hi,

I've filed a bug for the import behaviour, because it correctly loses imports sometimes.. I'm going to add a comment to that, as I'm pretty sure I know what it is now..

If there are curly bracket problems, or you are editing code that while you're file is in an invalid state (like moving a method signature up or down - anything that results in an invalid statement.. then appcode will remove imports from any code that was invlaidated by the edit - I've just seen a big class I use for mappings, lose 10 imports due to this..

so..
there is a question here I promise.

I personally NEVER want appcode to remove any imports unless I press CTRL+ALT +O, to manually say "clean up my imports please"..

Is there a setting for that?

Auto add imports. yes please, do it as I type, offer me alt enter hints.
Auto remove imports. No - never ever ever ever do that.

Does that already exist? If so, how do I set this?

Thanks.

George

2 comments
Comment actions Permalink

I've found the unused import warning setting in preferences.. I've disabled that.. hopefully that will kill the bug..

it's amazing to think how much I rely on and love this feature.. even now, with it just playing up a bit, and sometimes, it makes my life harder..

how the hell did I work before appcode? :)

0
Comment actions Permalink

The discussion has been moved to the related bug report: http://youtrack.jetbrains.com/issue/OC-4329.

0

Please sign in to leave a comment.