disable generation of instance variables when generating properties

Hi, how can I do this?

It seems it asks me on a per class basis when I synthesize a property, if I want to generate an instance var.. I NEVER want to generate an instance var. if I accidentally answer wrong, then that is it - in the future it will always generate an instance var.

How can I change that option for a file?

better still - how can I disable it forever, for every single file in the project?

Many thanks,

George

1 comment
Comment actions Permalink

The question dialog has a checkbox "remember the choice" that will disable the dialog forever. To re-enable it, go to preferences | code style | code generation, there are three options for ivars - always generate, never generate and ask.

0

Please sign in to leave a comment.