Cannot run one testmethod directly

Hi,

First of all: thanks you for the awesome work you are doing with AppCode.
It really made my development more productive since I started using it!

I'm having the following issue. A few hours ago, I decided to run 'File - Invalidate caches', because for some reason AppCode was becoming very slow.
When I now want to run one test method of a test class, I'm seeing the following popup, saying the test method can't be found:

Screen Shot 2012-05-15 at 16.50.08.png

However, when I hit run, I get the following popup:

Screen Shot 2012-05-15 at 16.50.16.png

When I click 'no' the test method just runs fine. Clicking yes brings me back to the previous popup.

While not being blocked by this behavior, it sure is quite annoying I always have to click twice now to run one specific test - which I didn't have to do before ...

Any clues how I can fix this?

3 comments
Comment actions Permalink

Joram,

What options does 'Method' combobox show? Does it recur with a new basic project?
Please try to isolate the problem and attach the project (or, at least a file with the corresponding test).

And thank you for the positive feedback!

0
Comment actions Permalink

The methods box shows all 14 of the test methods nicely.

I tried it with a new project, but couldn't reproduce it.
I'll try to isolate the problem when I find some spare time. For now, I'll just have to live with the extra click.

0
Comment actions Permalink

After a crash just now (tried to rightclick + run debug), it all works again now :-)

0

Please sign in to leave a comment.