Python 2.6 warnings when using python 2.7

Hello,

I'm using the most recent version of PyCharm (2.6.2) with python 2.7.2. In my code the Analyzer seems to show errors for something specific to python 2.6.

E.g.
"Python version 2.6 do not support multiple context managers"

Is it possible for the PyCharm Analyzer to not check something specific to an older version of python that I am not using? This didn't happen prior to upgrading to PyCharm 2.6+.

Thanks.
3 comments
Comment actions Permalink
Please press Alt-Enter on such an inspection report and either turn off the compatibility inspection or specify the correct range of Python versions that you want your project to be compatible with.
0
Comment actions Permalink
Hello. That's quite an old thread but I've run into the same issue with PyCharm v3.0
I'm using remote python 2.7.3 interpreter and I see python 2.6 errors like "Python version 2.6 does not support dictionary comprehensions"
More than that - python inspection called "code compatibility inspection" is turned off.
0
Comment actions Permalink
We need to revisit this because I tried turning off compatibility inspection, as well as selecting only python 2.7 let's say and the warning persists. I also delete the .idea on the project and reconfigured it to no avail. I can live with it for now but it's a sore thing to look at a yellow bar. Thanks in advance!
0

Please sign in to leave a comment.