AppCode 1.0 Can't find Apple Frameworks -- everything error/red in file

I'm glad AppCode 1.0 is out, but unfortunately everything in my source files is showing up as an error / red color.  NSString, NSObject, etc.  Says it can't find "Foundation" in the #import <Foundation/NSObject.h>.  Any ideas?  When I go into preferences under 'Xcode', it does indeed see my Xcode 4.2 installation (4.2 (4C199)).

I had the beta installed.  I've already invalidated my caches.  Is there some setting I'm missing, or something I need to delete?  Note that I have the app installed in /Local/Applications, not /Applications, but that shouldn't matter.

- Eric

3 comments

Errors like this are in my console:


10/25/11 5:52:49 PM [0x0-0x1242241].com.jetbrains.AppCode[99638] Can't resolve:  <Foundation/NSObject.h>
10/25/11 5:52:49 PM [0x0-0x1242241].com.jetbrains.AppCode[99638] Can't resolve:  "TCStreamProtocols.h"
10/25/11 5:52:49 PM [0x0-0x1242241].com.jetbrains.AppCode[99638] Can't resolve:  <Foundation/NSObject.h>
10/25/11 5:52:49 PM [0x0-0x1242241].com.jetbrains.AppCode[99638] Can't resolve:  "Exceptions.h"

0

Eric,

is the selected Run Configuration valid? How is it configured?

0

There was no Run Configuration selected.  Once I selected one, everything fixed itself.

0

Please sign in to leave a comment.