I can't debug on my device in appCode - can you help?

Every time I try to debug on my device I get this error;

4:06:04 PM Error transfering path
4:06:04 PM Stopping debugserver
4:06:04 PM Throwable: Assertion failed:



I am using iOS5, ARC and LLDB

I am running AppCode RC - but I haven't been able to debug on device in any version.

My system is 10.7.2
MBA

Hope that someone can help, because I would like to be able to stay in AppCode the whole time.

Best regards
Anders

14 comments

Hi! Please make sure that automatic Wi-Fi sync is turned OFF. It's a problem for us. but it will be fixed in release.

0

Thanks for the input,

However it didn't change anything.
I tried it on my MBP as well - same problem.

0

please append this to your AppCode.app/bin/log.xml:

<category name="#com.jetbrains.cidr.execution.debugger">
     
<priority value="DEBUG"/>
     
<appender-ref ref="CONSOLE-DEBUG"/>
   
</category>

Then please reproduce the problem and attach log (~/Library/Logs/appcode10/idea.log)

0

I've uploaded two logs here: http://cl.ly/BF2x
One where I included the suggested append inside the body of the tags there (v2) and one where I just added it at the end of the file.

I did manage to get a small project running on the app today,
but the one I am working on doesn't work - which it does in xcode.

Thanks for your help!

0

The second one contains name of your application bundle. And filename contains non-ASCII chars. That was the problem.
Please try to put AMDeviceService attached to AppCode.app/bin/ and try again. Please let me know it the fix works.



Attachment(s):
AMDeviceService.zip
0

Thanks for your help, that worked perfectly!

0

Welcome. I'm not sure if this fix will be included in release build. If not, please use this version of AMDeviceService.

0

Just bought the release - congrats on getting it out!
However the release cant debug on a device - with- or without your fix.

But now I am getting a new error:

9:15:14 PM Build Started
9:15:42 PM Build Finished
9:15:49 PM Looking for connected devices...
9:15:49 PM Installing application...
9:15:49 PM Transfering Path
9:16:09 PM com.jetbrains.cidr.execution.ipcUtils.ProtobufTimeoutException: Waiting for reply from LLDB for too long.
9:16:09 PM Stopping debugserver



Latest log is here: http://cl.ly/BGHs
0

Anders,
we greatly appreciate time you spend helping us and will do our best to deliver the fix ASAP.

Could you please try switching debugger to GDB and see if the problem remains?

Thanks,
Anton Makeev

0

Produces the same error;
com.jetbrains.cidr.execution.ipcUtils.ProtobufTimeoutException: Waiting for reply from LLDB for too long.
Eventhough it's switched to GDB.

0

That's kind of weird, this code should not be called if the debugger is set to DGB.
Please take a thread-dump with jstack.
After that try restarting both AppCode and the device and try running with GDB again.

0

Still the same error after restarting appcode and rebooting device.
Dump from before restart is here: http://cl.ly/BGOy

0

Anders,

I've created a bug report for this problem, please follow it and feel free to comment and add dumps/screenshots to it.
http://youtrack.jetbrains.net/issue/OC-2256

Thank you very much!

0

Please sign in to leave a comment.