Structure Expansion Not Working

I was recently given a license (the company I work for purchased one for me) to PyCharm.  Another developer here uses it and introduced me to a helpful feature that does not seem to work for me - Structure Expansion.

To give a specific use case:

We are developing a site with Django and I'm editing a views.py file.  We have a class-based view that has several mixins and I needed to override a function from one of the mixins.  He was able to expand the structure to see all the methods available, click one of the methods and it would navigate to the definition of that method.

When I try and expand the structure it says "loading..." for a moment then nothing happens.  The grey arrow disappears and I no longer have the option to expand the class.  This seems to happen for everything in the structure area.

Any ideas about what I can do to get this feature to work correctly?  It's obviously not enough to prevent me from successfully developing, but that is nice feature that prevents me from digging through my virtual environment to get to the Django files and searching through them for classes and methods.  bleh...
2 comments
Could you please try to use File | Invalidate Caches and restart?
0
This worked perfectly, thank you!

Is there a way to mark this thread as "Solved" or "Resolved"?
0

Please sign in to leave a comment.