AppCode quits instantly when trying to launch!

First i have to say how excited i am about the otential of this app. How i've longed for something to replace Xcode not to mention an editor with this type of "intelligence". That being said my joy was short lived after i tried to import my settings into AppCode. Now whenever i try and launch the app an alert pops up briefly and the program exits. From what i could tell from launching the app 10 times to try and read the error its saying:

Cannot launch Java Application

Uncaught Exception in main method

java.lang.AssertionError:com/sun/jna.library

I have tried removing every trace of the app on my machine, including everything in Preferences and Application Support, and re-installing with no luck. Same thing happens. Btw i also installed this on my laptop and the same thing happened. And yes these were settings i created and exported from AppCode and not some other IntelliJ editor.

Machines:

iMac: Lion, Xcode 4.1.1, AppCode-108.1068, java 1.6.0_26-b03-384 64bit
MBP: Snow Leopard 10.6.8, Xcode 4.0.1, AppCode-108.1068, java 1.6.0_26-b03-384 64bit

Also i found that on my MBP the app would always freeze when trying to quit or close a project?

Tony

2 comments
Comment actions Permalink

*bump*

I have deleted every file i could find containing *idea*, *intellij*, and *appcode*, rebooted, re-installed AppCode and it still refuses to launch. Are there any other files stashed somewhere that i should be deleting?

Thx

0
Comment actions Permalink

Hi,
I guess this is a known issue that will be fixed in the next eap, meanwhile please delete ~/Library/Caches/plugins/* (there should be action.script file present, if this is the problem I think of).
Let us know if this helps or not.

0

Please sign in to leave a comment.