Pycharm 2.7 "Native file watcher executable is outdated"

Hi, after updated to Pycharm 2.7 show always a warning that say:

"External file changes sync may be slow
Native file watcher executable is outdated"

warning.png


what does exactly mean this warning? have I compatibility problem with my system?

my system is:
ArchLinux, kernel 3.7.6, kde 4.10

thanks!
12 comments
Comment actions Permalink
That means pycharm/bin/fsnotifier* files do not have length PyCharm expects them to have.

How did you do the update?
0
Comment actions Permalink
Hi Roman,

this is the AUR package: https://aur.archlinux.org/packages/pycharm/
and this is the pkgbuild file: https://aur.archlinux.org/packages/py/pycharm/PKGBUILD

Can you check if there is a problem?
thanks
0
Comment actions Permalink
Not sure how it handles update. If I got it right, new version is just written over existing. Then yes, it may cause problem.
0
Comment actions Permalink
the binaries fsnotifier and fsnotifier64 are of new pycharm version 2.7, I have uninstalled the old version and make clean installed of new version.

$ pacman -Ql pycharm |grep fsnotifier     
pycharm /opt/pycharm/bin/fsnotifier
pycharm /opt/pycharm/bin/fsnotifier64

$ pacman -Qi pycharm |grep Versión        
Versión           : 2.7-1

$ ls -l /opt/pycharm/bin/fsnotifier*      
  • rwxr-xr-x 1 root root 18044 feb  8 10:24 /opt/pycharm/bin/fsnotifier
  • rwxr-xr-x 1 root root 23040 feb  8 10:24 /opt/pycharm/bin/fsnotifier64
0
Comment actions Permalink
add attach (log):
idea.log (6.2KB)

I tested Pycharm and works normally, maybe this is a little bug...
0
Comment actions Permalink
Hi, I'm too seeing the same warning in PyCharm 2.7.
My system have the same specs than Xavier's: Arch x86_64, KDE SC 4.10, Kernel 3.7.6-1-ARCH with Oracle's Java JDK 7.13 installed:

j:0 /opt/pycharm/bin $ ./pycharm.sh
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
[   2443]   WARN - api.vfs.impl.local.FileWatcher - Native file watcher executable is outdated

Please let me know if you need further logs.
  • Martin
0
Comment actions Permalink
The reason for this to happen is because MAKEPKG by default strips all binaries from debug symbols, this includes the version symbol that PyCharm uses to identify any potential updates.

Long story short:
1. Download PKGBUILD manually (https://aur.archlinux.org/packages/py/pycharm/PKGBUILD)
2. Add options=(!strip) to the PKGBUILD anywhere before the build() function
3. Rebuild and install
0
Comment actions Permalink
fixed!, thanks a lot Pontus, the package in AUR is already updated.
0
Comment actions Permalink
I added to the PKGBUILD in AUR options=(!strip).
0
Comment actions Permalink
Sergey, could you please also notify maintainers of phpstorm and IDEA packages?
0
Comment actions Permalink
Roman, I wrote a post in the comments on the pages of these packages in AUR.
0

Please sign in to leave a comment.