Issues with build

Hi guys,

I've been using AppCode for probably the last three months, and it's just great. I recently got into an issue with building the app, though, and I have filled a bug, but I thought that maybe somebody here would know a workaround.

Here's the issue: I have a Workspace with two projects inside, one being a library and the other an app that uses the library. Dependencies are set properly, and XCode can build and run the app correctly.

In AppCode, though, I get this error:

ignoring file /Users/___/Library/Developer/Xcode/DerivedData/___-enrzdjxxtzkiyrevsqmecqoolman/Build/Products/Debug-iphoneos/lib___.a, file was built for archive which is not the architecture being linked (i386)

All projects are set to build for Arm7, and to NOT build active architecture only. I have tried changing the architecture to all the ones available, but that didn't work. It doesn't matter what I do, I always get the same message.


Does anybody has any idea of things I could look for to get this solved? Going back to XCode is a nightmare. Here's the issue: http://youtrack.jetbrains.net/issue/OC-1141?projectKey=OC

Thanks guys!

Eduardo Scoz     

Please sign in to leave a comment.