endless spaces at the ends of lines

Is there any way to ditch the endless spaces automatically inserted at the end of every line? It is really screwing up my mouse and keyboard navigation; I click to what should be the end of a line and instead I end up in the middle of nowhere, and can't get back to the semi-colon without holding the left arrow for 15 seconds.

4 comments
Comment actions Permalink

Settings | Editor | Virtual Spaces | Allow placement of caret after end of line.

Altough you can get to a semicolon by pressing End (or Fn+Right)

0
Comment actions Permalink

Ah, very nice, thank you. I looked at that option a million times but never actually checked it since I had no idea what it meant.

Not sure if you are an Appcode developer, but if you are, this app is like sweet ambrosia after using the horrific monstrosity that is XCode 4. The mere existence of Appcode has probably saved me from a guaranteed brain hemmorage from trying to use XCode. Thanks.

One thing I would like to see is better control over how the tab bar works. It gets pretty clumsy when it gets up to 2+ lines, especially when the tabs start switching lines (depending on which is active), which drives me nuts, since I like to keep my tabs in very specific heirarchical order and this causes them to start moving all over the place. Would love to see them stay on one line and simply made slimmer as the bar fills up; right now it'll add a new row when there is still plenty of free space.

I'd also love an option to toggle between source/header files within a tab, rather than it opening a new tab. Other than those two minor issues though, I'm totally loving it. Keep up the good work.

0
Comment actions Permalink

> Would love to see them stay on one line

Settings | Editor | Editor Tabs | Show tabs in single row.

Though it probably better be a default...

0
Comment actions Permalink

awesome this drove me crazy as well

0

Please sign in to leave a comment.