How to run on device?

Hi,
I'm using latest drop of appcode (106.624) and while everything's fine with the default configuration (i.e. Debug on Simulator), I can't seem to get it working with a physical device.
What I did is create a new configuration (which I named "Device") for the same target application and then choose "iOS 4.3" in the "SDK" dropdown menu.
As soon as I do that, regardless of what is selected as "Architecture" (i.e. Standard (armv6 armv7), armv6, armv7 etc. etc.) the "Device" dropdown menu becomes dimmed, saying "not selected" and I can't do anything.
I have tried with both an iPhone 3GS and iPhone 4, not jailbroken, with latest iOS 4.3.3.
Trying to build with this configuration fails saying "Error running Device: iphoneos platform is not supported".
Looking at the logs, as far as I can tell, everything seems fine since I can see the following lines at startup:

2011-05-08 13:24:35,955 [   3458]   INFO -            #com.jetbrains.cidr - Configuring SDKs for Xcode 4.0.2 (/Developer)
2011-05-08 13:24:35,978 [   3481]   INFO -            #com.jetbrains.cidr - Platform configured: 'iOS 4.3 (iphoneos)'
2011-05-08 13:24:35,992 [   3495]   INFO -            #com.jetbrains.cidr - Platform configured: 'iOS 4.3 (iphonesimulator)'
2011-05-08 13:24:36,015 [   3518]   INFO -            #com.jetbrains.cidr - Platform configured: 'Mac OS X 1.0 (macosx)'
2011-05-08 13:24:36,026 [   3529]   INFO -            #com.jetbrains.cidr - SDK configured: 'Mac OS X 10.6 (macosx10.6)' for platform: 'Mac OS X 1.0 (macosx)'
2011-05-08 13:24:36,037 [   3540]   INFO -            #com.jetbrains.cidr - SDK configured: 'iOS 4.3 (iphoneos4.3)' for platform: 'iOS 4.3 (iphoneos)'
2011-05-08 13:24:36,042 [   3545]   INFO -            #com.jetbrains.cidr - SDK configured: 'Simulator - iOS 3.2 (iphonesimulator3.2)' for platform: 'iOS 4.3 (iphonesimulator)'
2011-05-08 13:24:36,044 [   3547]   INFO -            #com.jetbrains.cidr - SDK configured: 'Simulator - iOS 4.0 (iphonesimulator4.0)' for platform: 'iOS 4.3 (iphonesimulator)'
2011-05-08 13:24:36,047 [   3550]   INFO -            #com.jetbrains.cidr - SDK configured: 'Simulator - iOS 4.1 (iphonesimulator4.1)' for platform: 'iOS 4.3 (iphonesimulator)'
2011-05-08 13:24:36,050 [   3553]   INFO -            #com.jetbrains.cidr - SDK configured: 'Simulator - iOS 4.2 (iphonesimulator4.2)' for platform: 'iOS 4.3 (iphonesimulator)'
2011-05-08 13:24:36,054 [   3557]   INFO -            #com.jetbrains.cidr - SDK configured: 'Simulator - iOS 4.3 (iphonesimulator4.3)' for platform: 'iOS 4.3 (iphonesimulator)'


The same project builds and runs fine on my devices from Xcode 4.0.2, which by the way, is the only Xcode I have installed on my development machine.

Am I doing something wrong or have I hit some kind of bug?

Thanks,
Andrea.
3 comments
Comment actions Permalink

Andrea,
Device support is not yet published - it will be available in one of the following eaps.

0
Comment actions Permalink

Oh, I thought that was already supported since this version...
Happy to find out I'm not having any particular problem then :)

Thanks,
Andrea.

0
Comment actions Permalink

We have just released the new build with device debug support, you can try!

0

Please sign in to leave a comment.