jasmine-karma test runner - cannot step into functions when debugging

Hi,

 

I have webstorm v11.0.3 installed as well as karma test runner. I'm developing an angularJS web app. Everything works fine and it shows me the test results when I run the test.

 

However when I run the debugger to look into issues it does not step into the called function.

If I put the breakpoint inside the function under the test, the debugger never hits it.

If I put the breakpoint in the test file and hit F7 it only jumps into the first line of the corresponding js file (not at the function that is called) and remains there.

I used to navigate through the whole project using the debuger on webstorm10, IDK what has changed after upgrading to v11 that broke the debugger.

 

any advise?

Thx

 

 

2 comments

looks similar to https://youtrack.jetbrains.com/issue/WEB-19036. Do you have coverage reporter enabled in your karma configuration file? if yes, try commenting it out, like:

 

reporters: ['progress', /*'coverage'*/]
0

worked like a charm! Thanks for the prompt response.

I still don't know how come it was working before.

0

Please sign in to leave a comment.