Tool windows not auto-hiding

I am running PyCharm 2.7.3 on OSX. I am trying to setup the Run Tool Window to auto-hide. I have tried both Docked and Undocked Modes. In Docked Mode I am running Unpinned Mode. This setup almost works. If the focus of the IDE is in that Tool Window, pressing the escape key or clicking anywhere outside that Tool Window will auto-hide the Tool Window.

However, if the IDE focus is in an editor pane and I run some code, the Run Tool Window becomes visible but does not receive focus. At that point the Run Tool Window will not auto-hide until focus goes to another Tool Window or the whole app is forced to repaint (by switching to another app and back).

Am I doing something wrong? Is this a PyCharm bug?

It seems the same behavior exists in IntelliJ 12.1.4 community edition on OSX. This suggests the behavior is consistent across the Jetbrains common code-base. I have not yet tried to see if this happens in PyCharm on Linux to see if the operating system platform makes a difference.

Thanks.
3 comments
Comment actions Permalink
No, you aren't doing anything wrong. Doesn't the Run window hide if you focus it and then focus the editor back?
0
Comment actions Permalink
The Run window does correctly auto-hide if I focus it (Command-4) and focus back to the editor (Escape). However, this is 2 keystrokes, which seems less ergonomic.

It seems like it would be great if there were an option so that when Run is executed, the focus automatically goes to the Run window. Then, simply pressing Escape would hide the Run window and go back to the editor.

I'm not exactly sure what the purpose of Tool Window auto-hide is if it takes so many key presses to make auto-hide work.

Is there any way to get the IDE to behave this way? Specifically, I'm looking for focus to go to the Run window when Run is invoked. Would I be the first person to ever ask for behavior like this? I think at lease some versions of Visual Studio could be configured this way. This is great for working on a small lc

Thanks Dmitry!
0
Comment actions Permalink
It used to behave like that, but the behavior (specifically for the Run window) was changed at some point. Right now there is no possibility to configure the behavior.
0

Please sign in to leave a comment.