Code Analysis - not working!

PyCharm 2.7.3, build PY 129.782 built on June 17, 2013

I have noticed that code errors are not being picked up at all by the Code Analysis. When I rollover the Eye icon, it says
"Performing Code Analysis
No problems found so far.
"

I thought that takes time the first time you start a project but It's been hours now.

There's definitely problems in the file as I intentionally made all sort of typos but nothing is being picked up.

I have:
1. restarted PyCharm - Failed
2. restarted the Mac - Failed
3. created another empty project - Failed
4. copied same project to my mac book pro - Works!

I have the exact same version on my mac book pro and that seems to work fine.

has anyone encountered this issue?
Screen Shot 2013-08-15 at 3.10.05 PM.png
7 comments
Hi Bach,

does it help if you use File | Invalidate Caches?
0
Thanks Ekatrina.
I tried but same result after restarting.

I have tried with negative results:
1. deleting .idea directory for that project
2. creating an empty Python project from scratch
3. Pointing to different Python interpreters
4. Invalidating caches

Here's the log after restart:


idea.log (8.2KB)
0
After further search I have reached this page
http://devnet.jetbrains.com/docs/DOC-181

I completely deleted the config directory in preferences
~/Library/Preferences/PyCharm20

and restarted.
it WORKS!!!

not sure what preferences got messed up along the way to break this
knowing I haven't changed anything other than the editor theme.

anyway thanks for your help.
0

I had this exact issue with 2016.3, the solution to wipe ~/Library/Preferences/PyCharm* works still

0

This is still happening with PyCharm 2017.2 professional

It's a shame it isn't getting addressed by PyCharm's team. I'm paying for this great application, but if I have to delete all my settings, this is really upsetting.

UPDATE: deleting the preferences folder DOES NOT solve the issue with this specific file.

0

I fixed this issue by externally renaming the file, deleting the corresponding.bak file, going into the editor, and externally renaming the file back to the original name.

0

File/Settings/Inspections/(return to default/reset) seemed to work.

0

Please sign in to leave a comment.