LiveEdit plugin doesn't reload tabs with remove server

I'm using remote server running on url like http://dev.my-remote-server.com:1234
Every time I change code, PyCharm syncs it with remote folder and changes appears on http://dev.my-remote-server.com:1234 and then Live Edit reloads only localhost tabs in Chrome, but not tabs with my-remote-server.com.

How can I get LiveEdit reloading tabs with my-remote-server.com?
5 comments
Comment actions Permalink
Hi Egor,

Which PyCharm and LiveEdit version and operating system do you use?
Does it work when you open your remote server tabs only?
Do you have the message “JetBrains Chrome extension is debugging this tab” for tabs for your remote server or for localhost tabs only?
0
Comment actions Permalink
Hi,

I'm using PyCharm 2.7.2, LiveEdit 0.4.129.2 and Mac OS 10.8.4.
It doesn't work when remote server tabs only opened.
I used to see the message “JetBrains Chrome extension is debugging this tab” for localhost tabs but then it disappeared (I don't know why), though these tabs keep reloading.

I forgot to say that domains linked to 127.0.0.1 in hosts file reloads fine in addition to localhost and 127.0.0.1, if it matters.
0
Comment actions Permalink
Do you have "Can accept external connections" checked in Preferences->Debugger->Javascript?
In case it does not help you could try PyCharm 3.0 EAP: http://eap.jetbrains.com/pycharm/ (LiveEdit has version 1.7 there (and works as a part of JavaScript debug session only)).
Please tell if it helps.
0
Comment actions Permalink
Do you have "Can accept external connections" checked in Preferences->Debugger->Javascript?


I didn't see this option in Preferences: http://i.imgur.com/G2PrDlI.png

But I figured out exact problem:

In Chrome plugin settings I specified url pattern like this:
http://dev.my-remote-server.com:9999/ (domain and "/" in the end)
http://i.imgur.com/OJ0w5Dt.png

And I realized that LiveEdit works fine on pages which has pathname in url, for example:
http://dev.my-remote-server.com:9999/some_path/some_page
LiveEdit reloads it.

But it doesn't work on pages without pathname, for example:
http://dev.my-remote-server.com:9999
http://dev.my-remote-server.com:9999/?foo=bar
LiveEdit doesn't reload it.

I tried to set another patterns:

http://dev.my-remote-server.com:9999
http://dev.my-remote-server*
http://*my-remote-server*

but they all are invalid (I see error "<my pattern> is not a valid URL pattern" in Chrome extension console). Chrome docs also say they are invalid: http://developer.chrome.com/extensions/match_patterns.html.


Is any way to make LiveEdit working on pages without pathname in url?
0
Comment actions Permalink
Please vote for http://youtrack.jetbrains.com/issue/WEB-9260 to receive updates on this issue.
0

Please sign in to leave a comment.