Embedded Terminal Key

I've recently started using PyCharm and am very happy with it but I have one fairly major problem with it. I've been using emacs keybindings, which has made my transition very quick and easy, but it also introduces a fairly major problem. When working with the embedded terminal all the PyCharm keybindings still apply including anything that's bound to Ctrl-X, which makes working with any editor basically impossible since nano, pico and emacs -nw all use that command for closing the editor.

Is there some way to get the embedded terminal to ignore the global keybindings or will I have to change them?
4 comments
Comment actions Permalink

Is there a solution to this yet? I have just encountered the same problem in CLion.

0
Comment actions Permalink

There's an option to override IDE shortcuts in [File | Settings | Tools | Terminal], please try tinkering with it.

0
Comment actions Permalink

Andrey Resler I tried with both "Override IDE Shortcuts" on and off, and unfortunately it didn't work in either case.

0
Comment actions Permalink

Unfortunately I could not reproduce the issue - e.g. I can close nano editor from the console with Ctrl+X in all scenarios. 

I assume the issue is specific to your OS/environment. Please submit an issue to https://youtrack.jetbrains.com/issues and provide detailed description, including [IDE logs](https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

Also I would suggest to install IntelliJ IDEA and test with it - if reproduced, it's better to report the issue in IDEA project.

0

Please sign in to leave a comment.