Open File or Project dialog window unresponsive with Very Large directories

When I use File -> Open Directory... or File -> Open... and I have to open a folder or file whose pathname contains a parent directory in which thousands of user home directories reside, the UI becomes totally unresponsive, i.e. hangs (PyCharm Community Edition 3.0.2 on linux).
Is there some way preventing the editor from wanting to index, search, or to show all these directories in the directory tree widget?

In the terminal that I used to fire up PyCharm, I see a lot of warnings generated e.g.
[7409859]   WARN - ewvfs.persistent.RefreshWorker - fs=LocalFileSystem dir=file:///home name=<SOME USER NAME>

Thanks in advance
You could try asking this in the IntelliJ EAP forum as well. I wouldn't keep my hopes up, though.

You wouldn't have access to all those home directories, so there shouldn't be too much additional scanning going on. Java Swing trees don't usually like thousands of nodes (depending on what thousands is), so the problem could be there. Probably the only way would be to avoid navigating there.

This is a major issue.

* why is it even opening and scanning all intermediate folders from the root to the folder the File Open dialog starts with?  It should not default to including folders above the home folder.  In our company, there are literally thousands of user home folders mapped into /home (all from some other actual NFS folders). I have to wait about 2 minutes for it to finish scanning the useless home folder.

* why is this company think that File Open Dialog behavior be changed from hundreds of well-behaved and understood applications across all the popular OS's?  It is a well user tested dialog behavior that doesn't need to be changed.

* there seems to be a forgotten application pattern: multiple threads--the UI components run separately from processes dealing with significant resources/data.



After an update I was unable to open the project I was working on, and I can't start a new project from existing files since the file dialog just sits there, empty. Home folder, desktop folder, root - nada, nothing, zip.

How can I edit a file if the editor won't read a directory listing? Isn't this something that was solved in the seventies?


+1 as well.

I've got the same issue here now, too. Just recently updated PhpStorm and now when I attempt to open a particular folder, it just shows "C:\" and that's all I can select. It will erroneously open just the C:\ root folder. Also, for some reason other folders (like ones on my desktop) will still open, but it still refuses to open the one folder I need to access (permissions are perfectly fine). See below for an example -- it's extremely frustrating. Note that C:\Users\patnelson\Desktop\my-folder actually does exist (just renamed it for privacy). 


The folder dialog can be convenient, but I don't see why I have to be limited to this slow/buggy UI when I could just easily copy/paste the path and have it simply open that path. Right now, the UI is so broken that literally the ONLY way I can open a new folder is to run it from the command line like so:

"C:\Program Files\JetBrains\PhpStorm 2017.2.3\bin\phpstorm64.exe" "C:\Users\patnelson\Desktop\my-folder"


After upgrading to Intellij release 2017.3, the various file open dialogs are not able to open my home directory and just sits spinning. This is a bug, because there were no issues in 2017.2 and the number of files/directories on teh file system has not significantly changed. Some other issue going on here. I have to manually type the path/filename to do the various operations.  


FWIW, a reinstall "fixed" it for me. Take care to have it keep your settings I think.


For me, it turned out to be that the IDE was exceeding the heap of the JVM, as the IDE log was full of out of memory errors. Odd thing is, the IDE UI never popped up a notice that anything was wrong. I know in previous versions, a message would pop up advising it was out of memory. Odd thing is, I had already set the JVM to have a max heap of 4GB, because that is what I set it to when previous versions advised out of memory. I increased it to 8GB and then the file open dialog issue stopped happening.  I have been watching memory use by the IDE process since, and it is just over 2GB. Not sure why it needed 8GB at that point. Must have been something going on that needed a burst. Indexing perhaps? Hard to say. 


On Linux/RaspberryPi use the path and kick off from the terminal.

./bin/ "/home/pi/Development/projectname"


...four years later...

Is this being worked on please?


As a work-around:

in your personal file (obtained via Help -> Edit Custom Properties...),

does inserting this line:




had no effect for me.


No difference with 


Every time this happen I need to reinstall IDEA, this really sucks


And now i can't get it to work anymore even reinstalling the whole app, ridiculous!


Just ran into this.  A reboot fixed it.


Edit: on Ubuntu 14


Having the same problem on a Raspberry Pi 2 Model B running Raspbian Jessie, idea.chooser.lookup.for.project.dirs=false had no effect. The "Open File or Project" dialog comes up with a folder icon and / displayed under the text entry box, the loading icon on the right starts spinning, freezes, and then everything stays frozen. :-(

I had PyCharm running just fine on it a couple years back with Raspbian Wheezy, but after my SD card got hosed I decided to replace it with a larger one running Jessie.


I am seeing the same hanging issue with 2018.2.3. Even increasing the JVM heap size to 8M didn't help. The file picker tries to expand all directories starting from "/" and if you happen to be in a large company with lots of users and NFS mounted directories it just freezes forever. Restarts don't work. This problem makes the product completely useless. I can't believe 4 years (almost 5) went by and still nothing.


Hi Adamian, 


First, let me say I am a user just like you trying to help another, and I agree that the various IDE's (this issue has been seen across more than just the python IDE) should provide more control over this functionality so that users can work around it according to their environment. 

That said, I am wondering if you are running the IDEas a user whose home directory is literally set to '/'.  I don't ever see my IDE trying to churn on directories that are above my own home directory, and whenever I choose a file "open" operation, it always starts right on my home dir way beneath the file system root. 

If this is the case, then setting the home directory on your unix account to something not so high in the tree would probably solve this for you. 


Like Grogan Z974, a reboot fixed this for me too.

AS 3.2, Running on Windows 7.


Same here. Is there a solution?


Hi everyone,

This issue may be relevant, but please report a separate issue and attach your logs folder zipped (Help | Compress Logs and Show in...) and we will investigate it.


It's Oct 2020, I'm using pycharm Community 2020.2.2 and I'm still having this problem.  Like other mentioned above I work in a company with hundreds of users and the open file dialog box insists on reading the whole directory tree and so it never finishes.  I asked around at the firm and the only thing I heard is 'that's why I switched to VSCODE'.  No one has a solution.  So, JetBrains, people at big companies are switching away from PyCharm because of this.  Why can every other program in the world handle this file opening problem but PyCharm can't? 

BTW - A workaround for those, like me, who are addicted to PyCharm : Run pycharm from the command line and give the directory of your project as an argument : <directory to project>

Hope it works for others.


Same issue - Ultimate 2020.3 on Windows10 (which I just recently upgraded to so we can use the Code With Me plugin )

A reboot seems to fix it - but I'm not prepared to reboot my PC each time I want to open a new project !!

Is there a fix for this ??


My workaround:

1) In my case, every time I open the dialog it defaults to /foo/bar/boo. And I found that /foo/bar is a directory with many descendants, and it seems that Intellij is stuck scanning it. 

2) BUT I don't need /foo/bar/. I only need /foo/bar/boo

2) So I ln -s /foo/bar/boo /foo/xyz

3) change default directories (Settings -> System Settings) from /foo/bar/boo to /foo/xyz .

4) Swap out /foo/bar/boo with /foo/xyz. I basically "sed -i" all /foo/bar/boo with /foo/xyz  , for all files in ~/.conf/ and ~/.jetbrain/


Please sign in to leave a comment.