PyCharm on Linux - How to disable Select-to-Copy Feature

Answered
Dear all,

Could anyone advice me how can I find a way to disable when running pycharm on CentOS machine "select-to-copy" action?
It is very annoying, as I cannot execute a simple replace word action I am used to do on Windows:
  • Select a Word A->Copy A->Select Another Word -> Paste (on Linux it Does nothing because as soon as you select another word, you overwrite the current buffer..)

Any advice is more than welcome!
Thanks!!
6 comments
Comment actions Permalink
That works for me, as long as I paste explicitly with Ctrl-V or the Paste menu command instead of middle-click.

(That behaviour is consistent with X Windows norms, things you explicitly "copy" go to one clipboard, which is different than the "primary selection" that happens when you select something.)

I'm using the current pycharm EAP (PY-133.673) on Ubuntu 13.10 with OpenJDK.
0
Comment actions Permalink
Hi Kevin!

Thank you for your reply. Somehow when I try to do the same, it still does not work for me.
I am using it on CentOS 6.4 and pycharm Community Edition 3.02.

Could you maybe suggest if there is anything I should check, such as settings, options? Because I heard from more people that this should be working OK as you described...

Thanks you!
0
Comment actions Permalink

I'm getting this 'select-to-copy' behavior on Debian Jessie. 

Selecting anything overwrites the clipboard with what is selected, very jarring and unexpected.  If this is something that needs to be changed at the OS level let me know.

0
Comment actions Permalink

Hi B! Do you experience this problem with PyCham built-in terminal? If yes - please try to disable Settings | Tools | Terminal | Copy to clipboard of selection option. Has it helped?

0
Comment actions Permalink

@Pavel Karateev

this problem is not related to terminal, it happens within the code editor. The disabling of the "Copy to clipboard of selection" doesn't help.
It looks like a PyCharm bug. I've created this bug report issue for its tracking.

0
Comment actions Permalink

After experiencing the same problem on VcXsrv X server on Windows (which is a fork of Xming), the solution was to cancel the "Clipboard my use primary selection" option in VcXsrv tray icon context menu.

From the youtrack issue it looks like it was always an X server configuration problem.

2

Please sign in to leave a comment.