SVN Error E175005

I have a Subversion 1.7.14 server that work perfectly, but when I try to use it with PyCharm (version 2.7.3 and 3.1.1) I always get this error:

svn: E175005: Path '/full/svn/path/with/project/folder' already exists

From the same computer where I use PyCharm (with MacOsX 10.9.1) I try to use svn from the terminal and it works perfectly.

What can be the problem?

What are you trying to do, what system are you on and which SVN server/working copy version are you using?
This is what I try to do:

On my workstation (MacOsX 10.9.1 with pycharm 2.7.3 or pycharm 3.1.1) I create a new django project.
Then I want to stare the project on svn.

On the server (ubuntu 13.10 wait svn 1.7.14 + apache) I create a new repo (svnadmin create myrepo)

From pycharm I do share to svn and I add my repo url ex: http://serverip/svn/myrepo

It ask me for User and password and I login. But when i click on commit i get the error E175005.

I try to use svn from terminal and it works perfect.
I get the error only from pycharm.

Thanks for help!

That sounds weird. By any chance, are there any .svn directories in your project? Maybe because you copied files and folders from another project under version control into your project? Or did you create your project completely from scratch on the client?

Just curious: can you create/delete folders in your repository on the server through VCS > Browse VCS? If that also doesn't work, the problem could be on the server side.

One final thought: In the settings (search for subversion) there should also be an option to switch between the IDEA builtin SVN library and the command line client. Maybe it helps switching to the command line client. Even if it doesn't, you should be able to see the command line calls on the console so that you can manually try to run them in the Terminal.

Hope that helps.
Yes, I create the project every time from scratch.
I tried on other pc with TortoiseSVN and I can enter inside the repo and remove or create folders.
I already tried to enable comand line svn but with no success.
Thanks for help.

Please sign in to leave a comment.