Failed to create JVM: error code -4

I didn't file an issue since is seems to be a dup of:

http://youtrack.jetbrains.com/issue/WI-20882

This started happening when PyCharm said it was running out of memory and popped up a dialog box suggesting I increase the memory allowance. Since the memory allowances were 512/259/64 MB I just doubled them all since I have 16GB.

After rebooting with only 5GB used and 10GB of memory spare I still get the error code 4.

Reducing the Xmx memory back to 512 MB in the pycharm.exe.vmoptions file solved my problem, at the risk I guess of potentially running out of memory again with my large projects.

I assume this is a limitation because PyCharm is 32bit? If so, is there a 64bit version available or planned?

Thanks,
Dave
1 comment
Comment actions Permalink
There are certain memory limits for 32bit JVM instances. I don't know how this is done with pycharm, but for IntelliJ there is idea.exe and idea64.exe. The former launches the 32bit vm, the latter a 64bit vm. Is this different for PyCharm?

FYI: You do not have to use powers of two for the -Xmx parameter of the vm.
0

Please sign in to leave a comment.