Pyramid 1.5 on PyCharm 3.1.2 won't run

Hey everyone! I'm extremely new to Python and wanted to give Pyramid a try.  I saw the Pro version of PyCharm supports Pyramid so I picked up a copy (I'm a long time user of other JetBrains products).  After I installed PyCharm and configured it with python 3.3.2 running on Ubuntu 13.10 I created a new Pyramid project using the starter template (I tried alchemy as well with the same result), but every time I try to run it without changes I get the following:

/usr/bin/python3 /usr/local/bin/pserve /home/aphistic/PycharmProjects/TestPyramid/development.ini
Traceback (most recent call last):
  File "/usr/local/bin/pserve", line 9, in <module>
    load_entry_point('pyramid==1.5', 'console_scripts', 'pserve')()
  File "/usr/local/lib/python3.3/dist-packages/pyramid/scripts/pserve.py", line 51, in main
    return command.run()
  File "/usr/local/lib/python3.3/dist-packages/pyramid/scripts/pserve.py", line 316, in run
    global_conf=vars)
  File "/usr/local/lib/python3.3/dist-packages/pyramid/scripts/pserve.py", line 340, in loadapp
    return loadapp(app_spec, name=name, relative_to=relative_to, **kw)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
    return loadobj(APP, uri, name=name, **kw)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 271, in loadobj
    global_conf=global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 454, in get_context
    section)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 476, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 406, in get_context
    global_conf=global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 328, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 620, in get_context
    object_type, name=name)
  File "/usr/local/lib/python3.3/dist-packages/paste/deploy/loadwsgi.py", line 640, in find_egg_entry_point
    pkg_resources.require(self.spec)
  File "/usr/local/lib/python3.3/dist-packages/setuptools-1.1.5-py3.3.egg/pkg_resources.py", line 673, in require
    
  File "/usr/local/lib/python3.3/dist-packages/setuptools-1.1.5-py3.3.egg/pkg_resources.py", line 576, in resolve
    if req in processed:
pkg_resources.DistributionNotFound: TestPyramid

Process finished with exit code 1
prettyPrint();

Does anyone have any tips on how I can get this running? I was also trying on Windows 8.1 before using Linux and ran into the same error.  I figured it was just Windows being Windows, so I switched to Linux.

Thanks for the help!
2 comments
I figured it out. So for the benefit of anyone else who runs into the same problem, the solution for me was to make sure you have your Pyramid project active in the project pane, then click Tools->Run setup.py Task..., then click OK on the arguments window that pops up.  It looks like this is pretty standard when you're working with Pyramid.
1

This is still an issue for 2016.2 distribution.   When you bring up Tools->Run Setup.py Task you will get a list of different things to run.  Select the "develop" task.

0

Please sign in to leave a comment.