Unit Tests using wrong interpreter?

(PyCharm community ed, 3.1.3)
I have two versions of my project in 2 directories (Let's call them trunk and hotfix). Both have unit tests, and their own interpreter. The only difference between the two interpreters is one has my trunk directory added to the paths, and the other has the hotfix directory.

However, both appear to be using the same interpreter (whichever is first in the list) when running unit tests. When I enter the "Run/Debug Configurations" screen, I can set the Python interpreter to either the trunk or hotfixes version, and get the same results. (I dropped a "raise Exception()" line in trunk.)

I have tried:
1) Invalidating Caches
2) Deleting and re-adding interpreters. (Changed which one was used, but didn't fix the problem.)

Any ideas?
1 comment
Did you try making separate configurations in the Run/Debug Configurations dialog?  I've done this successfully.  For me, one execution was local and the other remote.  It worked fine.  Although this seems obvious, maybe I don't understand your issues.
0

Please sign in to leave a comment.