pycharm remote interpreter: how to stop ssh login popup every 10 sec?

I'm running the latest (paid) version of pycharm, and just set up a remote interpreter, but it is unusable because I get a popup window showing the host's ssh login message every few seconds. It seems like pycharm is displaying the login notice every time it connects, which is very often, to the remote machine (see screenshot below).

Is there a way to stop pycharm from showing this popup; otherwise the remote debugging is not useful to me.

Notes:
  • I tried setting loglevel=quiet in my .ssh/config (did not help).
  • FYI: I got the remote interpreter to work after failures where pycharm said it could not find the remote interpreter or its lib.so files. Initially I ran 'which python', which gave a path that PyCharm would not accept for a remote server, saying it could not find the libpython2.7.so.1.0
file. Then I tried using 'realpath `which python` to get the real path to the interpreter, and that did not work either as pycharm said it could not find the interpreter, but when I used the pycharm GUI to navigated to the realpath of the interpreter, that remoter interpreter configuration was accepted by PyCharm.

Please sign in to leave a comment.