Git integration - nothing to commit, no changes detected

Problem: Git > Add doesn't seem to do anything, and Git > Commit File says "No changes detected", when git from the command line sees changes and can commit/push files.

Details:
I'm using PyCharm PE 3.4 (evaluating it) on OSX Mavericks.

I have a project that I've clone from Github. Git is configured. I can call "git status" from the terminal and it lists several files that have been changed and are not staged for a commit yet. My .git/config file lists a remote "origin" at github. Both "github" and "git integration" plugins are enabled in the Preferences -> Plugins menu. Under Version Control > Github my connection is configured and tested as working properly. Under Version Control > Git, the git interaction is properly configured and tested as working.

If I change a file in my project (the file is shown in blue now) and I right click and select "Git > Add" nothing happens. If I do "Git > Commit File" a dialog box pops up and says "no changes detected". Under the "Changes" tab at the bottom, under "local" no files are listed. However, if I call "git status" from the terminal, the changed files are listed, and I can add, commit, and push them just fine.

No matter what I do, I can't seem to get PyCharm to play nicely with git. Any suggestions?
8 comments
Comment actions Permalink
That's pretty weird. I don't suppose you have multiple changelists in PyCharm? They would show up in the Changes tab, the default one being named "Default".

Does Git > Show History work? E.g. select the project root in the Project window, right click, Git > Show History. And have you tried Settings > Version Control > Git > Path to Git Executable > Test?
1
Comment actions Permalink
"Default" is the only changelist. It's empty. Git > Show History is ghosted out.
Yes, the Git executable works and is tested:

  Git executed successfully
  Git version is 1.8.4.0
0
Comment actions Permalink
Maybe the pycharm project does not know that it is supposed to use Git as its Version Control tool? Maybe you need to click `Enable Version Control Integration...` from the `VCS` menu (available only when no VCS has been associated with the project or directory) and select Git to associate it.

See https://www.jetbrains.com/pycharm/help/associating-a-project-root-with-a-version-control-system.html
0
Comment actions Permalink

William, did this ever get resolved for you? I just encountered the same thing using Jetbrain's Rubymine 2016.2.3.

Thanks, dvn

0
Comment actions Permalink

Currently having this issue with version 2017.1 and this started with previous 2016.x update.  Workaround has been to create a new blank project and moving the module there but this eventually happens again.  Git history view is blank but 'compare with branch' seems to work.  Having to run git commands from terminal is getting annoying...

0
Comment actions Permalink

Not sure if this helps anyone, but we have experienced this issue (for obcious reasons) for files that are available through symlinks internal to the project. Not sure if it counts as a bug, but a feature supporting redirects to the original paths for files available through symlinks (directories or the files themselves) for git would be neat

0
Comment actions Permalink
Settings > Version Control > Git > Path to Git Executable > Test

Thanks for this hint Planders, that solved the same problem in my case. I had uninstalled the old 32Bit version of Git and had to rewire it with PHPStorm.

1
Comment actions Permalink

Issue is still present.

0

Please sign in to leave a comment.