Pycharm Performance on Windows Remote Desktop

Hi,

I like using PyCharm 3.4.1 alot on my local machine.

However I experience severe GUI performance issues when it comes to working on it over remote Desktop Connection (with moderate bandwidth like 16Mbit)

It takes ~1 s to refresh the whole screen. While other applications like Internet Browser or Eclipse work with very small lack compared to local execution.

I've already done some research on this topic and I found this hint:

http://russelldavis.blogspot.de/2011/02/how-to-fix-horrible-performance-of-java.html

I also recognized that the described option sun.java2d.noddraw=false

can even be altered in the idea.properties file in the PyCharm  installation directory.

Unfortunately changing the setting didn't improve the situation at all ...

Any hints are welcome.

Best Regards
Steve
4 comments
Comment actions Permalink
Nobody ? Nothing ?
0
Comment actions Permalink

Hi Steve,

 

Did you ever get this resolved?  PyCharm is basically unusable over remote desktop.  I really don't want to go back to Eclipse but this might be a deal breaker.

Did you find  this setting?

#---------------------------------------------------------------------
# Use default anti-aliasing in system, i.e. override value of "Settings|Editor|Appearance|Use anti-aliased font"
# option. May be useful when using Windows Remote Desktop Connection for instance.
#---------------------------------------------------------------------
idea.use.default.antialiasing.in.editor=False

 

I just changed the setting you found on russell davis's blog and this antialiasing setting.  I will have to try remote desktop when i get home.

0
Comment actions Permalink

Hi,

am actually using this feature per default.

However, the most effective way to boost screen update performance on pycharm under remote desktop was setting the color depth of the remote desktop connection to 16 bit, which cuts the used bandwidth by half.

another option you might want to try is:

#---------------------------------------------------------------------
# Workaround for slow scrolling in JDK6
#---------------------------------------------------------------------
swing.bufferPerWindow=True

 

1
Comment actions Permalink

Hi Stephan,

Thanks for the update.

Yes I found that reducing the color depth was a huge improvement.  Reducing it to 24 was a huge improvement I'll give 16 bit a try too cause I am still getting some slow down.  I'll check out that bufferPerWindow setting.  I not sure why JetBrains doesn't advertise these settings.  

 

Chad

0

Please sign in to leave a comment.