django and breakpoints partially (but seriously) broken with pycharm-3.4(.1)

Linux (ubuntu 14.04), Python-2.7, oracle/jre1.8.0_20.

pre-note: I don't remember having this problem previously (since I have installed 3.4).

Anyway : when I debug a django project, break points work ok during startup (runserver) but once started/running break points don't work ; like inside a view function for instance, though when the module of the view function is imported break points work well during that import inside the module.

I tried removing my .idea folder, re-testing, restarting pycharm many times, also removing my .PyCharm30 folder and retrying from zero but it's always the same. I also tried the various debugger options: No reload, single, gevent, etc.. I also tried with different debug configurations values (working directory, content & source roots added to python path) but always always same behavior, as far as I can see.

The work around I used: downgrade to pycharm 3.1.3 and now it's ok.

If you want I can produce more infos to help.

Please sign in to leave a comment.