How to disable mouse/trackpad *completely* in editor?

I use IdeaVim plugin, which is awesome, except of one annoyance. When I'm in "insert mode", I sometimes accidentally hit the touchpad/mouse, and then the caret starts typing in a different location. Similarly, sometimes accidental touchpad hits selects random regions in the editor.

Note that I already have "disable touchpad when typing" in my OS (debian+gnome). So I'd like to solve it at the PyCharm level, rather than the OS. Also because, these incidents usually happen after I pause for a second to think, so the OS does not know that I'm still "typing".

I already disable everything mouse-related in Settings/Editor, but that does not help.

Since I do not need the mouse/touchpad at all, I would love to disable it completely when I'm in the editor pane. (If that's not possible, a second-best solution would be to disable mouse/touchpad completely in PyCharm).

Please sign in to leave a comment.