Says package "installed successfully", but doesn't actually install

Answered
I'm trying to get the LiveWires package to install in PyCharm setup, which appears to temporarily "install" but only if I add the parameter "–allow-external", however when I close the install dialog window, back to the Project Interpreter, it isn't there listed with the other packages I installed.  There are other packages that are like that too.  How do I get those to stick?

In the program when I try to import it ("from LiveWires import games, colors")  I also get this error:
ImportError: No module named 'LiveWires'

Well, yeah ... it didn't appear to stick when I "installed it"so go figure.  How do I use this package?

I'm using python3.4 and PyCharm4.0 Community.

Thanks in advance!
26 comments
Is there something I need to do manually.  For example I put the package in the project directory, or some other directory, change a file or two?
0
Services pack 1 keeps failing to install on the second stage. I have tried to install it about 8 or 9 times now but still the same. It just completes the first stage then fails.
0
Can someone help?  Is this common for PyCharm to not really install a package, or is something wrong with my setup, and is there a way around it?  My boy is learning Python, using the horrible "IDLE" IDE that came with his book "Python for Absolute Beginners", but at least he can import the LiveWires modules with the IDLE IDE.  No such luck with PyCharm.  Is he better off using Eclipse with PyDev?
1
from LiveWires import games, colors


try changing that to

    from livewires import games, colors

If that doesn't work, make sure that the in Preferences > Project Interpreter that the livewires module is installed in the python that your project is using (it is possible that you have more than one python installation, and each one has it's own sets of libraries).

What platform are you on?  Windows/Mac/Linux?
0
If the package is installed successfully nothing will be printed on the prompt, but if an error occurred during installation it will be reported. It is possible to install several packages at once by writing several package files after the pkg install command.
0

Having this exact problem.  PyCharm 2018.1.1, Python 3.6.

Project > Project Interpreter shows updates available.  When clicking 'Update', it loads for a bit then shows the 'Package installed successfully' message, but the update is still available.  Similarly, trying to install a new package will load and give the success message, but will never add the package to the library or the interpreter's package list.

 

The version never changes.  I've tried running as a standard user and in administrator mode.

1

Having the same problem with PyCharm 2018.1.1 and python 2.7 on Ubuntu 16.04. Any workaround for this one?

2

Update: reinstalled Python and PyCharm, still having issue.

0

Do you mean that you cannot update only pip and setuptool? If you do, it's a known problem that will be fixed in one of the upcoming PyCharm 2018.1.x updates (presumably 2018.1.2).

For the time being the workaround is to update them manually from Terminal.

0

Same problem here on 2018.1

 

Funny thing is that it worked ok with os and csv but panda and matplotlib causes this problem.

0

This solved my problem. My pycharm version is 2018.01.

https://stackoverflow.com/questions/49768770/not-able-to-install-python-packages-ssl-tlsv1-alert-protocol-version

 

  1. Run virtual environment with shell. (replace "./venv/bin/activate" to your own path)

    source ./venv/bin/activate
  2. Run upgrade

    curl https://bootstrap.pypa.io/get-pip.py | python
  3. Restart your pycharm, and check your python interpreter in Preference.

0

Another approach that worked for me (in an environment lacking 'curl', and without using a virtual environment) is to download this file manually: https://bootstrap.pypa.io/get-pip.py - and then save it in my project directory. Then I had to open Pycharm as administrator, then run that get-pip.py file with the project interpreter - this installed the latest version of pip, and after that I was able to re-open Pycharm as a normal user and install packages normally.


 

0

Hi everyone,

There are two different but intertwined problems described here.

The first one is that it's not possible to use and upgrade pip using the standard "pip install -U" from within PyCharm caused by the changes on PyPI. I'm afraid the only way to handle it at the moment is to update the tool manually using get-pip.py as mentioned above.

Another one is a recent regression introduced in 2018.1.1 causing PyCharm not to report any errors that happened during a package installation. It's already been fixed in 2018.1.2 RC. Please try upgrading the IDE and let us know if it helped.

0

First: I did what influenz suggested 

  1. Run virtual environment with shell. (replace "./venv/bin/activate" to your own path)

    source ./venv/bin/activate
  2. Run upgrade

    curl https://bootstrap.pypa.io/get-pip.py | python
  3. Restart your pycharm, and check your python interpreter in Preference.

Result: pip was upgraded from 9.0.1 to 10.0.1 

THEN 

 

I did what Mikhail Golubev suggested and upgraded PyCharm...

 

Package appJar installed correctly but I cannot install other packages like PIL. IS that normal?

 

Tried PIL ... and got an error

 

Looking in indexes: https://pypi.org/simple/
Collecting PIL

Could not find a version that satisfies the requirement PIL (from versions: )
No matching distribution found for PIL

 
0

It seems that PIL is one of those packages that while listed on PyPI doesn't keep any actual releases there and at least judging by PyPI stats it has been abandoned for quite a while. You won't be able to install in from Terminal either. Don't you need to install Pillow instead?

0

Do u gonna update the IDE to solve this problem or i must do it manually ?

 

0

The problem with not reporting installation errors is already fixed in 2018.1.2. Updated version of pip for new virtual environments should be included in the next bugfix update. For existing ones you need to do it upgrade it manually at the moment, I'm afraid.

0

I have 2018.3 on OS X and I have the problem with no errors being reported.

 

Any package that I try to install simply is not installed and gives no error.

 

 

0
Hi Gary, Thank you for contacting JetBrains support. On your screenshot I don't see any error. Instead I see that package 'jupyter' was successfully installed, but doesn't appear in the list of installed packages. Since you're using virtualenv environment, I suggest we first ensure that PyCharm is installing the packages in the correct environment. Please do the following: 1. Ensure that virtual environment is associated with the current project, see the screenshot: http://bit.ly/2thzffK 2. Open terminal in PyCharm, ensure the proper virtualenv is activated, and do `pip list`, compare the output with what you see in project interpreter settings Please let me know how it goes.
0

Yes. It’s my settings are correct. Here is the output:

 
$ pip list
Package    Version
---------- -------
pip        10.0.1 
setuptools 39.1.0 
You are using pip version 10.0.1, however version 19.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
(venv) 
 
 
One extra piece of information I can give you is that the package is indeed being installed but in completely the wrong place:
 
/usr/local/lib/python2.7/site-packages/
0

It seems PyCharm uses wrong virtualenv for some reason. Can you please try **File > Invalidate caches / restart**, then create a new virtualenv interpreter for your project, and install try installing new packages there?

0

Hi Gary,

Did you launch PyCharm as superuser to silently install a package under /usr/local/lib/python2.7/site-packages/ directory?

Also, what happens if you try to install "jupyter" using "pip install" command directly for the same venv interpreter in terminal?

If it doesn't clarify anything, could you please create an issue in our tracker attaching idea.log (Help | Show Log in Files). There should be a record showing how exactly pip was launched and with which interpreter.

0

Hi Mikhail,

I have solved the issue (see below).

There was an invisible

~/.config/pip/pip.conf 

file. That contained these lines:

[global]
target = /usr/local/lib/python2.7/site-packages

Perhaps though PyCharm could catch something like this, and give a warning like suggesting to use  

pip config list


should it not appear
.

0

So, basically, you suggesting that PyCharm should warn if the package is installed in a directory, that is not looked up by PyCharm's package manager (or rather by pip list)? I think that's a good suggestion.

Please feel free to submit a corresponding feature request to our issue tracker using the link https://youtrack.jetbrains.com/issues/PY and let us know if you need any help.

0

Please sign in to leave a comment.