How can I remove Python versions from "Code compatibility inspection"?

I'm using Pycharm 4 and I wish to use code compatibility inspection. However, the inspection checks compatibility with some Python version which I'm not interested to be compatible with, such as Python 2.4. The inspection description says "The range of Python versions with which the code needs to be compatible can be specified in the inspection settings.". However, while I can see the list of Python versions, I cannot find any way to change it.
1 comment
Comment actions Permalink
I ran into this myself and it took some time to figure out, but simple once I did. Pycharm shows a list of Python versions in the settings and I had assumed that I should be able to select one or more and delete from the list. Not finding a context menu or other means, I suspected a code bug in the IDE. But I found that I can select one or more, then click Apply or OK and those I selected are the ones checked for. Obvious once you see it.

Any glitch here is that when the settings panel opened initially, no Python versions were displayed as selected, giving no clue how to toggle the versions as active or not. I found that on subsequent re-opening of the settings, my chosen subset is displayed as selected. (This with PyCharm community 4.0.6 on fully updated Win7x64 SP1).
0

Please sign in to leave a comment.