Remote interpreter creation stuck at "Getting remote interpreter version"


I've installed PyCharm on my new Windows 8.1 operating system.
Unfortunately, despite PyCharm installing fine, I can not create a remote interpreter connection.

I'm remotely connecting to the same Linux machine I usually do (which worked fine on Windows 7), but PyCharm seems to be stuck somewhere in the SSH process - It shows "Getting remote interpreter version" for hours. I've tried adding PyCharm to the Windows firewall exceptions, but that didn't help at all.

I should also note that PyCharm's built-in SSH client connects fine to that machine, in addition to other SSH utilities (e.g. Putty).

I've attached PyCharm's log file, along with screenshots of the part where the remote interpreter hangs.
Thanks a lot for your help, and have a great day!

Edit - I'm not seeing the attachments, so I've uploaded them here:
Comment actions Permalink
I have exactly the same problem. It looks like the ssh connection window gets hidden in the back, or something like that, so it doesn't advance...

I'm also in win 8.1. Any idea of how to solve this?
Comment actions Permalink
This seems to be a bug in version 4.x.
Check this out -

Please sign in to leave a comment.