Bug with symlinks and (separately) Run/debug configuration under Linux

In my home directory, I have a symlink to the location where I keep my coding projects.  PyCharm gets confused by this.  When debugging, for instance, and a breakpoint is hit, PyCharm opens a tab referring directly to the file rather than going through the symlink.  It leaves the original tab open.  Breakpoints remain set on the original tab, but are invisible on the new one (though still effective).  Edits on one tab result in getting a 'file has changed' warning and prompt to reload when switching to the other.  At times I have also run into PyCharm apparently cacheing the file, where no modifications made get picked up (even though 'cat'ing the file in a terminal shows them present) until PyCharm is restarted.  Both are very annoying issues.

The second problem I run into on a regular basis is when creating a run/debug configuration.  After clicking the 'Add New configuration' button (the green plus), a submenu (of sorts, its not a standard submenu, it looks like a separate window) is displayed.  The problem is, this submenu is only a handful of pixels tall and not resizable.  It has to be navigated with the keyboard and it is not possible to read all of the options.

I hope this forum is the correct place to file bug reports.  If not, I'd appreciate a pointer to where I should submit these bugs.  Thanks in advance for any information!

Same issue here. Pycharm also gets confused as to whether the files is tracked by Git or not and asks you if you want to add the absolute path of the file, although the symlink is already added to Git.


Ctrl clicking through a function opens the function in the symlink as well


Same problem of invisibile breakpoint with phpstorm :(


Hi Dustin,

We had a few reports of the same issue, but unfortunately I couldn't reproduce it in our lab. I've tried symlinking the whole project directory or individual files - breakpoints are hit normally and no another tab opens.

Can you please try to reproduce it a new minimal project? We need to know the steps necessary to reproduce the issue before we can report a bug to our developers.


We have a couple of similar issues for other IDEs:

PHPStorm: https://youtrack.jetbrains.com/issue/WI-600

CLion: https://youtrack.jetbrains.com/issue/CPP-10963

Both can't be reproduced. Maybe this time we'll be lucky.


Same problem running PyCharm Professional 2019.2.3 on Linux Mint (ext4 filesystem).

I have a symlinked directory several levels up from where I keep my projects and PyCharm gets confused when trying to debug, always opening the source in another tab, even when the source file is already open. When I try to edit from this second tab I get a dialog stating the I'm trying to edit a file outside the project.

Please let me know if I can help debugging or making it easier for you to reproduce this issue. I can confirm that the problem is related with symlinks, since I work on the same project in another notebook where there's no symlink on the project path, and it works correctly.

This is a really annoying bug, as it gets in the way of debugging every time.



Please sign in to leave a comment.