Pycharm failing to catch unresolved references

Pycharm 4

Generally I expect pycharm to highlight errors when I have references to unimported or incorrect references. But lately pycharm is not finding them.

I am on OSX Yosemite. I have tried invalidating caches and restarting, wiping my .idea folder, removing the app and all the associated files (

still no go. Any idea what i'm missing?

I'm not in powersave mode highlighting level is set to max. Still nothing

Screenshot 2015-03-06 12.21.26.png

Screenshot 2015-03-06 12.23.56.png

Screenshot 2015-03-06 12.24.36.png

Screenshot 2015-03-09 10.07.36.png
Comment actions Permalink
I don't see the screenshots. You can edit your post and include with !filename.png!

Have you checked Settings -> Editor -> Inspections -> Python -> Unresolved References?
Comment actions Permalink
Thanks for the top on the screenshots. Ill check my editor when I get to work tomorrow and let you know what i have it set to
Comment actions Permalink
Added my unresolved references setting

Please sign in to leave a comment.