Numpy install error

Trying to install numpy 1.9.2 into Pycharm 4 (running python 3.4)  (on windows 8)

keep getting  error: Microsoft Visual C++ 10.0 is required (Unable to find vcvarsall.bat).

i upgraded by setuptools and pip versions (14.3 and 6.0.8 now respectively)

tried running pip install –upgrade numpy from the command line

i installed VS C++ 2008 and ran from command there.
i tried to install 2010 but it wont let me (says a newer version is installed despite my attempts to rid any trace of a newer version from the machine)

i tried to fake it out and put the vcvarsall.bat file in the right path where 2010 would be

no matter what still the same error.

please help.  I like pycharm and would like to stay on it, but starting to be tempted recommendations of others that come with numpy already included
3 comments
Comment actions Permalink
Try to install numpy in the command line. Do you have the same result?
Please, check the following answer: http://stackoverflow.com/a/5983696/3598790.
0
Comment actions Permalink
I tried to install numpy in the command line (running "pip install - - upgrade numpy", let me know if thats not right), got the same error (Microsoft Visual C++ 10.0 is required (Unable to find vcvarsall.bat).)

I checked the answer you linked but am not sure how it applies to my situation.  Can you be more specific about what you are suggesting?

Thanks for your help.
0
Comment actions Permalink
Try to install compilled numpy version (from http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy) for your project interpreter in the command line  and then please restart PyCharm.
0

Please sign in to leave a comment.