Tab Character Problem

PyCharm Professional Edition 4.0.5

I set 'use tab character' and unchecked smart tabs.  This seemed to work at first, then just... doesn't.  All I get now is spaces, so I actually have to copy and paste tab characters.  I tried with the setting off, and again with the setting on, and it does not change behaviour.

I've already invested in using the tab character so I won't be changing that.

The spaces appear when:

  • using the tab key
  • pressing enter after something that should have an indented line after it (e.g. if ...:)
  • inserting a doc block start (""") and pressing enter inside a function

How to I resume using tab characters by default?
4 comments
Comment actions Permalink
Hello,
Please, invalidate caches (File| Invalidate Caches and Restart). Does it help?
0
Comment actions Permalink
Hi Anna, I invalidated the cache and restarted and that didn't make any difference.
0
Comment actions Permalink
I set 'use tab character'


Please clarify where did you set it? In Settings| Editor| Code Style or in Settings| Editor| Code Style| Python ?
0
Comment actions Permalink
Anna, yes, that is the answer, it is fixed now.  I wrongly assumed settings "for current project" would work for the current project.
0

Please sign in to leave a comment.