Pycharm latest update - now freezing and unusable on 2 different computers

I have the latest version of pycharms installed 4.0.5

However it now just completely freezes on opening and 2 different computers.  Both are running OS X Yosemite.

Is there something I can do to diagnose the issue - is this happening to anyone else - as now Pycharms is unusable for me.
9 comments
The same thing is happening to me. I just installed the 4.0.5 update and now it freezes on startup. I am, however, running OSX Mountain Lion and not Yosemite. Any help would be much appreciated!
0
Hi, please submit an issue to yourtrack.jetbrains.com/issues/PY and attach there a thread-dump (there you can read how to do it: https://intellij-support.jetbrains.com/entries/23348667)
0
Thanks I tried to create a dump with stack but get the error:
jstack -l 1865 dumppy.txt
Attaching to core dumppy.txt from executable 1865, please wait...
Error attaching to core file: Core files not yet supported on Mac OS X

?? Any ideas (I've raised a ticket)
0
Hi Dimitry, Also happens Yosemite and 4.0.6, pretty frustrating. It runs for a while, about 10 min at most, then some activity kicks in and then it freezes. It appears that it will go and try to find the auto-complete info for something that I know that does not exist.

It was OK pre-upgrade to 4.0.6 as far as I know. I will file a bug definitely and would like to help you fix it.
0
Request #57784 "PyCharm After Update to 4.0..." created. The jstack and also idea.log file are attached. It appears that something starts then it run too long and runs out of memory.
0
I have been on the Windows PyCharm and it has been working fine for the past 3 hours. Also when I filed an issue, I can no longer find it (as I did it without logging in to the Jetbrains account.) I will try to post it again.
0
Ticket 57804 added now.

This is the first part of the crash:

2015-04-06 14:32:15,263 [  41299]   INFO - packaging.PyPackageManagerImpl - Running packaging tool: /Library/Frameworks/Python.framework/Versions/3.3/bin/python3.3 /Applications/PyCharm CE.app/Contents/helpers/packaging_tool.py list
2015-04-06 14:34:51,208 [ 197244]   INFO - ellij.vfs.persistent.FSRecords - Creating VFS corruption marker; Trace=
java.lang.Exception
java.lang.Exception
 at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection.createBrokenMarkerFile(FSRecords.java:193)
 at com.intellij.openapi.vfs.newvfs.persistent.FSRecords$DbConnection.access$2600(FSRecords.java:137)
 at com.intellij.openapi.vfs.newvfs.persistent.FSRecords.invalidateCaches(FSRecords.java:1616)
 at com.intellij.ide.actions.InvalidateCachesAction.actionPerformed(InvalidateCachesAction.java:99)
 at com.intellij.openapi.actionSystem.ex.ActionUtil.performActionDumbAware(ActionUtil.java:164)
 at com.intellij.openapi.actionSystem.impl.ActionMenuItem$ActionTransmitter$1.run(ActionMenuItem.java:266)
 at com.intellij.openapi.wm.impl.FocusManagerImpl.runOnOwnContext(FocusManagerImpl.java:926)
 at com.intellij.openapi.wm.impl.IdeFocusManagerImpl.runOnOwnContext(IdeFocusManagerImpl.java:124)
 at com.intellij.openapi.actionSystem.impl.ActionMenuItem$ActionTransmitter.actionPerformed(ActionMenuItem.java:236)
 at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
 at com.intellij.openapi.actionSystem.impl.ActionMenuItem.fireActionPerformed(ActionMenuItem.java:105)
 at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
 at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
 at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
 at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
 at com.apple.laf.ScreenMenuItemCheckbox.itemStateChanged(ScreenMenuItemCheckbox.java:196)
 at java.awt.CheckboxMenuItem.processItemEvent(CheckboxMenuItem.java:389)
 at java.awt.CheckboxMenuItem.processEvent(CheckboxMenuItem.java:357)
 at java.awt.MenuComponent.dispatchEventImpl(MenuComponent.java:351)
 at java.awt.MenuComponent.dispatchEvent(MenuComponent.java:339)
 at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:743)
 at java.awt.EventQueue.access$300(EventQueue.java:103)
 at java.awt.EventQueue$3.run(EventQueue.java:699)
 at java.awt.EventQueue$3.run(EventQueue.java:697)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
 at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
 at java.awt.EventQueue$4.run(EventQueue.java:713)
 at java.awt.EventQueue$4.run(EventQueue.java:711)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
 at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:748)
 at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:577)
 at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:384)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
0
I heard back from Anna at JB Support, and the suggestion was to remove setup folders. In my case that's under ~/Library/Preferences/PyCharm40 I did that.

Interesting thing might be is that it was stable until when I set the default Python interpreter, it started some process again and back into the same freeze.

Still cannot use the Mac to develop Python for this reason, and using Windows 8 which works fine.
0
Update: I have tried CE 4.5 EAP (with built-in JRE 8) and that does not hang on the same machine. And also the previous version 3.4.1 does work without a problem. I have tried to switch the JRE on 4.0.5 to 6 and 7 and that did not help. There must be something fundamentally different in 4.0.5 compared to others. I also use the IDEA Ultimate and that never gave me the same type of issue. If any of you are experiencing the issues with 4.0.5, you could try these two versions and avoiding 4.0.5.
0

Please sign in to leave a comment.