Enable pretty printers with mingw-64

Hello all,
I am using CLion 1.2.1 with mingw-64 and GDB 7.8. Whenever I run in debug mode, I get an error saying "STL pretty printers are not initialized for C:\libs\mingw-64\bin\gdb.exe". When I build using normal MinGW, everything is fine, but I am currently working in a project where mingw-64 is needed.

Any suggestions on how I can enable pretty printers?

3 comments
Comment actions Permalink

Hi Joseph.

Could you please execute 'python print "test"' command in the debugger console and send us the result?

0
Comment actions Permalink

It seems that python scripting is disabled in mingw-64 gdb (I'm with nuwen MinGW, GCC 5.3). The STL printers are written in python right? I may ask Stephen to enable python scripting in his distro, but that solves the problem there only. Anyway, this doesn't look like a clion issue but a platform one.

1
Comment actions Permalink

I've been playing with this too and had not much luck,  kind of stopped trying to get pretty print working as pretty print doesn't display my data pretty anyway,  it works 75% as advertised and I just use the old cout to debug the rest. 

Options I've not tried is to use the MingW that Jetbrains recommends for Clion and copy the LIBS and LIBRARY files from Stephen distro to the LIBS / LIBRARIES of the recommended install.
Or use the MingW that Jetbrains recommends for Clion and use Conan.io to build the boost or other libraries I need.



0

Please sign in to leave a comment.