Add nodejs source code to External Libraries

Hi,

In the previous versions of WebStorm, once node.js was enabled in the project, it used to add the source code of Node.js to the "External Libraries" under the project tree. Looks like it stopped doing that in WebStorm 11, is there a way I can restore that behavior?

Thx.

6 comments

it still works for me in WebStorm 2016 - on project opening, local node_modules folder is added to javascript libraries (unless it's excluded from project). If this doesn't work for you, you can add it manually: in Settings | Languages & Frameworks | JavaScript | Libraries, press Add.. , then hit Alt+Insert to attach a folder

0

Hi,

I am not referring to the node_modules lib but to the Node.js source code itself.

Here is a screen shot where I enable node.js for the project (in webstorm 11)

Then when I go to Settings | Languages & Frameworks | JavaScript | Libraries I can't see the "Node.js Core Modules" added.

On the other hand, when I do the same on WebStorm 9, you can see that the Node.js Core Modules is added:

As a result, the node.js source code is added to the External Libraries:

0

Ah,

looks like I found it, the node.js source code is under:

%HOME%\.WebStorm11\config\javascript\nodejs\0.12.2\core-modules, so I can add it manually... this used to be automatically...

0

> I can't see the "Node.js Core Modules" added

 

Please see your own screenshot - can't you see 'Node.js Core' there? It is the library you are looking for:) And it's enabled. 'Node.js Core Modules' and 'Node.js Globals' from previous releases have been merged into a single library - 'Node.js Core'. And yes, it doesn't appear under 'External libraries' node in Project view.

 

0

LOL, I was locked on the "Node.js v0.xxx Core Modules" like in previous versions so I didn't see the shortened text...

Anyway, what I was looking for is the node.js source code, I think it is very helpful to have this on the External Libraries.

0

Please sign in to leave a comment.