[SOLVED] Clion on Archlinux, error displaying IDE

Hey Guys, I just installed Clion on Archlinux and it looks horrible, it took me a while trying to use my JetBrains account to register my copy thinking it could help but everything is the same, I've noticed PhpStorm and IntelliJ looks fine, it's only a problem with Clion. Any ideas?

Here is the screenshot:
ssClion.png

If i try to click something (when cursor turns to pointer) just big blocks of windows appear, no text anywhere.

Edit: forgot to mention, I'm using openbox.

/www.pinterest.com/pin/create/extension
4 comments
Comment actions Permalink

Hi Carlos.

Could you please specify which JDK are you using? We suppose that you use different JDK versions (for example, bundled JDK for CLion and system for PhpStorm or vice versa).

0
Comment actions Permalink

Hi Anna!
     I apologize for not updating this thread, I x-posted this question in Archlinux forums and solved it.

tl;dr:

Setting in 

/etc/profile.d/jre.sh

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'
0
Comment actions Permalink

Carlos,

Thank you for your details and sorry for the delay with answer.

0
Comment actions Permalink

No problem! Hope this helps! I love everything from JetBrains! :x

0

Please sign in to leave a comment.