Cannot get CLion to respect any tab size / indent size settings

Hi,

I cannot seem to be able to change the default of 4 spaces for indentation. No matter what I set in the Settings panel, CLion is indenting 4 spaces. This is especially maddening since I am working on an existing project that is indented with 2 spaces each.

I have tried the options Tab size, Indent, Continuation indent, and Detect... None of them seem to affect anything.

For example, here is a file indented like the sources I am working with.

// -*- mode: c++; indent-tabs-mode: nil; tab-width:2  -*-
#pragma once

#include <string>
#include <iostream>

namespace myspace
{
    std::string some_call(std::string const &a,
                              std::string const &b,
                              std::ostream *c);

  class MyClass
  {
  protected:
    std::vector<int> const *m_member;
  };
}


The editor is indenting with 4 spaces. It is driving me crazy. Can you help?

I have attached the settings screen I believe should do something for me. Using recent CLion 1.1.1.

Thanks,
David

Attachment(s):
indent.png
1 comment
Comment actions Permalink

Hang on, I did not realize there is an extra panel for C/C++ specific settings. :)

indent1.png
Problem solved.

1

Please sign in to leave a comment.