Integrated GDB, and a frame not available error

Hello,

I am trying to debug a C++ program, and I have a breakpoint set. When I try to inspect local struct or step into function in the same class even, the debugger stops and the GDB user interface show the message 'Frames are not available'. Here is the output from the GDB window:

GNU gdb (GDB) 7.8
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
python
>>>>>warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
warning: File "/usr/lib/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
     add-auto-load-safe-path /usr/lib/libthread_db-1.0.so
line to your configuration file "/home/jd/.gdbinit".
To completely disable this security protection add
     set auto-load safe-path /
line to your configuration file "/home/jd/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
     info "(gdb)Auto-loading safe path"
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.

Breakpoint 1, GLWindow::createWindow (this=0x7fffffffe4a0) at /home/jd/Documents/rendtest/GLWindow.cpp:21
21         if (!Window) {


Any ideas? I'm running arch linux on x86-64 hardware.

Thanks

3 comments
Comment actions Permalink

Hi Jeremiah.

Could you also please add the following line to (Help | Configure Debug Log Settings)
#com.jetbrains.cidr.execution.debugger

and send us idea.log file (Help | Show log in ) after the problem will happen again.
0
Comment actions Permalink

I've sent a log with a similar issue on Arch Linux x86_64.

Workaround: go to File -> Settings -> Build, Execution, Deployment -> Toolchains

Use specified GDB and select /usr/bin/gdb.

CLion will complain that this gdb is more recent than 7.8.x and is not supported. If this causes problems, the AUR has a package called gdb78. That should fix the warning and any related problems.

0
Comment actions Permalink

Same issue here on Arch Linux. Even though when GDB is set to autodetect it claims to find it correctly, frames are not available. Manually selecting gdb fixes this.

0

Please sign in to leave a comment.