Project View - why do I have a full Project View ?

Hi,

since one of the last updates, my Project View is full with
Qt5CoreConfig.cmake
Qt5CoreConfigExtras.cmake
Qt5CoreConfigExtrasMkspecDir.cmake
...
Qt5WidgetsConfigVersion.cmake
Qt5WidgetsMacros.cmake
--
For Information: Example of absolute Path of these sub-cmake-stuff is /Qt/qt54/lib/cmake/Qt5Core/Qt5CoreConfig.cmake

I do not want this in my Project View !

I guess it*s because of my main CMakeLists.txt which contains ...

Qt5Core)
find_package(Qt5Widgets)
find_package(Qt5Gui)
find_package(Qt5OpenGL)
find_package(Qt5Network)


So i Opened Settings/File Types and in TextInputField "Ignore files and folders"
I added "*.cmake" . Result was, my Project View was without *.cmake .... but CLion had Exceptions!

So I switched back and have to live with this Qt-cmake-stuff which spoils my Project View ?
This is too much. Clean Project View is most important for me.

I guess philosophy from jetbrains is to let CLion show as much CMake Infos as can be.
But this should be switched on/off (some how) because I want to concentrate on my work and not on CMake.

Greetings
Olaf




Attachment(s):
clion-spoiled-project-view.png
1 comment
Comment actions Permalink

Olaf,
it's was neither intentional nor is a part of JetBrains philosophy, here is a bug report: CPP-4251.
Please accept our apologies for the inconvenience

0

Please sign in to leave a comment.