Color Escape codes not rendered in Console

In the output console, the bash escape codes are not interpreted correctly.
For example, when running gtest (Google Test) tests, this is the output:

/home/marco/workspaces/linux/mongo_fw/build/Debug/mongo_fw --test

WARNING: Logging before InitGoogleLogging() is written to STDERR

I0719 19:05:15.143045 20529 main.cpp:69] Running 0.2

I0719 19:05:15.143168 20529 main.cpp:71] Running unit tests for Playground App

[0;33mNote: Google Test filter = -ExamplesTest.*

[m [0;32m[==========]  [mRunning 0 tests from 0 test cases.

[0;32m[==========]  [m0 tests from 0 test cases ran. (0 ms total)

[0;32m[  PASSED  ]  [m0 tests.

This should obviously be instead rendered via green/normal fonts.

Does anyone know how to set it so that it shows color correctly (if at all)?

3 comments
Comment actions Permalink

Try GrepConsole plugin, then enable ANSI colors

0
Comment actions Permalink

I tried GrepConsole, but there is no change after installing this plugin. There is also no option in the preferences to ENABLE ANSI COLORS.

Any idea?

0
Comment actions Permalink

Ive had this break on my system too but only when running php 5 scripts in bash terminal within phpstorm running in windows.

it also seems like php storm remembered some state for the terminal and never lets it go.
If I reinstall phpstorm from scratch after cleaning the system its normal again.
but then sync my settings with my account and its broken again.

And if ai change to using php7 in cli its fixed.


I tried addressing this with jet-brains support and got nowhere.

I just had a colleague have this happen to him as well. Only happens on his home machine and not his work machine but unlike me it also does it to him with php7. 

 

In the end the only way I could fix it was by reinstalling phpstorm and not syncing my account settings and starting again.

0

Please sign in to leave a comment.