Error: "cc is not able to compile a simple test program"

What I did when this happened:
I attempted to build a fresh project, which uses cygwin and built in cmake as a tool chain.
In addition I tried to build a project that worked before -> doesn't work either.

Bitdefender had put cmake in quarantine before the issues started, but I restored the file and got rid of Bitdefender (currently using Windows Defender).

What's happening:
Please see the attached errors.txt file which contains the full error message.
Basically cmake can't compile *anything*.

About my setup:
Windows 8.1 Professional x64 - English, Clion 1.0.3 BUILD #CL-141.873
cygwin is located at D:\cygwin and calling cc/gcc/g++/make/cmake directly from the Cygwin Terminal works just fine.
Clion has been installed to the standard path C:\Program Files (x86)\JetBrains\CLion 1.0.3

What I did try to resolve this issue:
I fully removed clion, including the .clion10 folder and I also chose to remove everything when uninstalling it.
I also fully removed cygwin (just to be sure), including the only two registry keys it uses and installed it again.
Bitdefender got uninstalled, I did a clean restart and I'm now using Windows Defender.

"Invalidate Caches/Restart" in Cygwin didn't fix it either (I didn't really expect it to do anything as a full uninstall/reinstall cycle couldn't help but I wanted to give it a try anyways).


I added d:\cyg\bin to my path variable, afterwards to the global variable and removed it again, no changes.



Attachment(s):
errors.txt.zip

Please sign in to leave a comment.