Is there a way to stop symbol indexing for some linked libraries?

Hi,

I've noticed that since I added a reference to boost_log and its afferent link libraries, clion started having huge indexing times for symbols (30 min - 40 min) and the whole IDE was barely usable (takes forever to go to a method definition from one of my project classes). This stopped immediately after I removed the link libraries.

Right now I completely removed boost from my project, but this isn't a compromise that I like. Is there a way that I can disable symbol indexing for some of the libraries that I'm linking agains? Or something similar that would speed things up? I don't mind it taking up lots of RAM as long as it runs fast.

My system:

Linux geko 3.13.0-39-generic #66~precise1-Ubuntu SMP Wed Oct 29 09:56:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz

MemTotal:        4046368 kB

SSD


Thanks!

9 comments
Comment actions Permalink

Unfortunately, it's not possible to disable indexing for some of the libraries.

It is likely that CLion simply needs more memory. You can check that by enabling memory indicator (Settings -> Appearance & Behavior -> Appearance -> Show memory indicator). If it is maxed out for a long time, then that's the issue. You can increase the available memory by changing Xmx parameter as described here.

0
Comment actions Permalink

Hi Vyacheslav,

That answers my question about stopping indexing.

It doesn't seem to be a memory problem. It never reached the maximum amount (2GB), in fact it was quite far from it.
Still, there's a huge difference in clion's responsiveness with and without linking to boost_log and boost_date_time. With linking clion is unusable on my machine. Now I'm curious if this is a more general problem or just something specific to my hardware.

0
Comment actions Permalink

No, the problem is not specific to your hardware, it is specific to boost, because it is a quite "heavy" library. Actually, potential problems with boost are listed in our known issues.

0
Comment actions Permalink

my 5 cents:
to stop lib indexing is a good idea. there are and there will be libs which will be horrible to index.....and if user do not want that, why not to turn off ?

0
Comment actions Permalink

Hi,

Is there a plan to fix this performance problem for the release or will it stay a known issue?
In my case clion is unusable if I link to a part of the boost lib and I'd be surprised if I were the only one. I wouldn't mind the lack of auto-complete&co for heavy libs as long as the IDE still works.

0
Comment actions Permalink

>  I wouldn't mind the lack of auto-complete&co for heavy libs as long as the IDE still works.
I agree totally!
C++ is not java so i do not expect 100% support in every situation.
First: In general major things must work. Edit, make, run.
Second: Autocomplete and other features.

0
Comment actions Permalink

This is another Kicad blocker, unfortunately.

0
Comment actions Permalink

Yes, we are working hard on performance improvements.
We'll roll out them gradually in the following EAP builds.

0
Comment actions Permalink

+1 on not indexing everything. I have given the JVM 4g but it only uses 1g... but it is very very slow.

I just want a way to exclude some directories and/or libraries.

Thanks!

0

Please sign in to leave a comment.