Issue with typing in the clion editor

Answered

Yesterday, I installed the last build 141.352 on my new MacBook Pro with OS X Yosemite v.10.10.2, and I have a very weird behavior when I create a new project and start typing in the editor. At the beginning I just cannot type anything, different buttons give some random behavior like delete line, delete word etc. After a few seconds of random typing it starts behave normally, and I can type what I want. But if I switch to a different document, again I have to push some buttons randomly until the keyboard starts to behave normally. If anybody have such a problem? Do you have any idea why it can happen?

9 comments
Comment actions Permalink

Hi Denis.

Could you please try to restart CLion or restart your machine, would it help?
Also please try to use another JetBrains IDE, for example RubyMine EAP which you can download through this link.
Will the problem still there?

0
Comment actions Permalink

Hi Anna,

Thank you for your reply! Of course I tried to restart. :) It didn't help... With PyCharm I have no problems.

0
Comment actions Permalink

Denis,

Could you also please specify which JDK are you using?
Do you use CLion version with bundled JDK or not?
It's interesting to try the IDE with 141. build, not PyCharm.
You also could try to use the latest WebStorm.
We want to test another IDE to exclude problems with the environment.

0
Comment actions Permalink

Anna,

jdk-7u75-macosx-x64.dmg
jre-7u75-macosx-x64.dmg

$ java -version

java version "1.7.0_75"

Java(TM) SE Runtime Environment (build 1.7.0_75-b13)

Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)

I tried with both RubyMine EAP and WebStorm it works fine for me.

I just tried to reinstall Clion with both bundled JDK and not. It still doesn't work. When I start a new project, I have:

 
#include <iostream>

using namespace std;

int main() {
    cout << "Hello, World!" << endl;
    return 0;
}


and cursor blinks like I would push insert button (blinking box). I cannot type anything with a random keyboard behaviour. Then I push different keys and at some point it starts blinking as usual, and I can type normally.

0
Comment actions Permalink

Denis, thank you for the details!

Could you please check that you have IdeaVim plugin disabled.



Attachment(s):
Screen Shot 2015-04-06 at 20.46.31.png
3
Comment actions Permalink

Great, it works now. I knew it was because of some vim/emacs stuff. Just didn't know that there such plugins activated by default. Thanks a lot for your help!

0
Comment actions Permalink

I have a same problem. Disable IdeaVim plugin solved this problem. Thanks a lot for your help.

0
Comment actions Permalink

Great!!!! i have same problem too and  disable IdeaVim  solved . u save my day and my anger :))

0
Comment actions Permalink

Thank you very much, disable IdeaVim solved my problem on macOS Mojave, version 10.14.1.

0

Please sign in to leave a comment.