clion cpu 100% and more on ubuntu

Hey guys,

I see a strange pattern , even that clion is
not "doing" any comilation or cache building
any heavy operation I do constanetly see
that the cpu is 100% and more.

Any idea ?

Thanks
Roman.

16 comments
Comment actions Permalink

Could you please provide a cpu snapshot and file an issue in our tracker? We'll investigate it.

0
Comment actions Permalink

too much to read , if you want my help I can do it ,
just make it short: I am on :

Ubuntu 14
jvm 7 , 64 bit

Thanks
Roman

0
Comment actions Permalink

Please, read there the 'CPU snapshot capturing instructions' part and follow the instruction there.

0
Comment actions Permalink

I have tried to start
clion with that option
and it doesn't start:

-agentlib:yjpagent

any othere ideas how to
profile for you this cpu
problem ?      

0
Comment actions Permalink

For the 64-bit JVMs -agentlib:yjpagent64 option needs to be used instead or the IDE will not start.

0
Comment actions Permalink

apparently it was starring by default all the time.
here is the snapshot during it the cpu was ~300%,

Cheers.
Roman



Attachment(s):
CL-138.1965_romanm_16.09.2014_15.34.13.zip
0
Comment actions Permalink

thanks! We'll investigate the case.
I've placed your description and snapshot to this issue: http://youtrack.jetbrains.com/issue/CPP-1080

0
Comment actions Permalink

I am having the same issue. The CPU utilization goes above 100% and the system stops responding — this is super frustrating. I am running it on an Alienware 17 R4. Please let me know if there’s a fix for this. Thanks

0
Comment actions Permalink

Hi, Ali.

Sorry for the inconvenience! Could you please capture a CPU snapshot and send it to clion-support at jetbrains.com? It would help us to investigate the issue.

0
Comment actions Permalink

Me too having the same issue. On Ubuntu 16.04 with KDE.

Enabling power-saving mode solves the issue, but I still want code insight.

After following that "CPU snapshot" guide, only "Capture Memory Screenshot" is available, like in the attached picture

0
Comment actions Permalink

Proposal, have you enabled the Profiler Agent as described in the "Enabling Profiler Agent" section?

0
Comment actions Permalink

Yes I had.

It only involves adding that "-agentlib:yjpagent64=delay=10000,probe_disable=*" to my vmoptions right?

At CLion startup, it complains about "Could not find agent library yjpagent64 on the library path, with error: libyjpagent64.so: cannot
open shared object file: No such file or directory"

So I use "LD_LIBRARY_PATH" to https://www.yourkit.com/java/profiler/download/ binary file for Linux x86-64, and renamed that "libyjpagent.so" "libyjpagent64.so" and it started, but it only shows the menu above.

I'm using CLion 173.4674.29 downloaded from Toolbox on Ubuntu 16.04 for x86-64.

0
Comment actions Permalink

Erica, for the 64-bit JVMs on Linux the line in VM Options should be

-agentlib:yjpagent-linux64=delay=10000,probe_disable=*

For 32-bit:

-agentlib:yjpagent-linux=delay=10000,probe_disable=*

The libyjpagent-linux.so and libyjpagent-linux64.so libraries should be located in the bin folder of CLion.

Sorry for the inconvenience.

 

0
Comment actions Permalink

I have captured the CPU Profiling data. How to attach the snapshot file?

Additional info: This only happens on CLion's code inspection on a single file in my project. It stuck at 7% in "Syntax analysis". The file is a C++ file with about 350 lines. It's a small project either, with only about 1000 SLOC in total, spread across 20 files.

0
Comment actions Permalink

Erica, you can send it to clion-support at jetbrains.com

0

Please sign in to leave a comment.